summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2024-10-02 21:22:19 -0400
committerDavid Thompson <dthompson2@worcester.edu>2024-10-03 07:12:23 -0400
commit567863b2398b6832f686b258709396572af0e980 (patch)
tree9876b28945a793fc6fedbd7f9804a0d7e159a47c /Makefile.am
First commit!main
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..a986f77
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,59 @@
+# guile-sdl3 -- Scheme bindings for SDL3
+# Copyright © 2024 David Thompson <dthompson2@worcester.edu>
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+GOBJECTS = $(SOURCES:%.scm=%.go)
+
+nobase_mod_DATA = $(SOURCES) $(NOCOMP_SOURCES)
+nobase_go_DATA = $(GOBJECTS)
+
+# Make sure source files are installed first, so that the mtime of
+# installed compiled files is greater than that of installed source
+# files. See
+# <http://lists.gnu.org/archive/html/guile-devel/2010-07/msg00125.html>
+# for details.
+guile_install_go_files = install-nobase_goDATA
+$(guile_install_go_files): install-nobase_modDATA
+
+CLEANFILES = $(GOBJECTS)
+EXTRA_DIST = $(SOURCES) $(NOCOMP_SOURCES)
+GUILE_WARNINGS = -Wunbound-variable -Warity-mismatch -Wformat
+SUFFIXES = .scm .go
+.scm.go:
+ $(AM_V_GEN)$(top_builddir)/pre-inst-env $(GUILE_TOOLS) compile $(GUILE_WARNINGS) -o "$@" "$<"
+
+moddir=$(prefix)/share/guile/site/$(GUILE_EFFECTIVE_VERSION)
+godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/site-ccache
+
+SOURCES = \
+ sdl3/config.scm \
+ sdl3/guardian.scm \
+ sdl3/bindings/utils.scm \
+ sdl3/bindings/error.scm \
+ sdl3/bindings/init.scm \
+ sdl3/bindings/video.scm \
+ sdl3/bindings/gpu.scm \
+ sdl3/errors.scm \
+ sdl3/video.scm \
+ sdl3/gpu.scm \
+ sdl3.scm
+
+EXTRA_DIST += \
+ pre-inst-env.in \
+ README \
+ guix.scm \
+ run-example \
+ examples/hello.scm \
+ examples/hello.bmp \
+ examples/controller.scm