summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson@vistahigherlearning.com>2016-12-30 11:19:48 -0500
committerDavid Thompson <dthompson@vistahigherlearning.com>2016-12-30 15:51:58 -0500
commitb833f588b3d9528e7fc650d841ee7a46b6c0ba78 (patch)
treee0a393cca717153abd6bbe0e59505f1901393469 /Makefile.am
parent2fb7f399f322122f2d5e5f436673fe386242505e (diff)
Add bindings for text input event handling.
* sdl2/bindings.scm (sdl-start-text-input, sdl-stop-text-input, sdl-is-text-input-active): New procedures. * sdl2/events.scm (<text-input-event>): New record type. (make-text-input-event, text-input-event?, text-input-event-timestamp, text-input-event-window-id, text-input-event-text, parse-text-input-event): New procedures. * sdl2/input/text.scm: New file. * Makefile.am (SOURCES): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 5428b13..9bddc71 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,5 @@
# guile-sdl2 --- FFI bindings for SDL2
-# Copyright © 2015 David Thompson <davet@gnu.org>
+# Copyright © 2015, 2016 David Thompson <davet@gnu.org>
#
# This file is part of guile-sdl2.
#
@@ -47,7 +47,8 @@ SOURCES = \
sdl2/surface.scm \
sdl2/render.scm \
sdl2/video.scm \
- sdl2/events.scm
+ sdl2/events.scm \
+ sdl2/input/text.scm
if WITH_LIBSDL2_IMAGE