summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2015-12-16 12:38:38 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-16 12:48:39 -0500
commit2751b1a7380d52ff14e1cd50eac8f042252a02ac (patch)
tree3c23f3ad4ad8cd7fba6aaac7920b5e30e6edb81d /Makefile.am
parent167f5e267686f4fd6019c6100777b96cc3706975 (diff)
Add event bindings.
So far, only window and keyboard events are handled. More to come in future patches. This patch adds a *ton* of constants that I'm not going to mention in this log because it would be too damn long. * sdl2/bindings.scm (sdl-poll-event): New procedure. * sdl2/events.scm: New file. * Makefile.am (SOURCES): Add it.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 543b734..80512fc 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,8 @@ SOURCES = \
sdl2/bindings.scm \
sdl2/surface.scm \
sdl2/render.scm \
- sdl2/video.scm
+ sdl2/video.scm \
+ sdl2/events.scm
EXTRA_DIST += \
pre-inst-env.in \