Allow building with Guile 2.2.