summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 66be3c0..2bc4ad7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,4 +33,14 @@ AS_IF([test "x$OPENAL_LIBDIR" = "x"], [
])
AC_SUBST([OPENAL_LIBDIR])
+PKG_CHECK_MODULES([Vorbis], [vorbis])
+PKG_CHECK_VAR([VORBIS_LIBDIR], [vorbis], [libdir])
+AC_MSG_CHECKING([Vorbis library path])
+AS_IF([test "VORBIS_LIBDIR" = "x"], [
+ AC_MSG_FAILURE([Unable to identify Vorbis lib path.])
+], [
+ AC_MSG_RESULT([$VORBIS_LIBDIR])
+])
+AC_SUBST([VORBIS_LIBDIR])
+
AC_OUTPUT