summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2019-12-19 08:18:26 -0500
committerDavid Thompson <dthompson2@worcester.edu>2020-04-07 16:10:23 -0400
commitadc7e0dbd1a5b511641e85c46f0e7894353f0cda (patch)
tree583480a03c56b292429f930da5d44f9c5ed47722 /configure.ac
parent2e917863a045bcecdfb08d16d92b6498ed29de38 (diff)
audio: Add mpg123 bindings.
* chickadee/audio/mpg123.scm: New file. * Makefile.am (SOURCES): Add it. * configure.ac: Check for mpg123 library.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2bc4ad7..a28d1fe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,4 +43,14 @@ AS_IF([test "VORBIS_LIBDIR" = "x"], [
])
AC_SUBST([VORBIS_LIBDIR])
+PKG_CHECK_MODULES([mpg123], [libmpg123])
+PKG_CHECK_VAR([MPG123_LIBDIR], [libmpg123], [libdir])
+AC_MSG_CHECKING([mpg123 library path])
+AS_IF([test "MPG123_LIBDIR" = "x"], [
+ AC_MSG_FAILURE([Unable to identify mpg123 lib path.])
+], [
+ AC_MSG_RESULT([$MPG123_LIBDIR])
+])
+AC_SUBST([MPG123_LIBDIR])
+
AC_OUTPUT