summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2021-12-17 08:56:20 -0500
committerDavid Thompson <dthompson2@worcester.edu>2021-12-17 08:57:16 -0500
commita9aa99ac55440b36fe0c2c647bcfa151f08bcce2 (patch)
tree39c860aec3bc0604f3ea93ed40d263d9c4e365b0 /configure.ac
parenta0aef712ab136b970b2cdb1d6f967bab1040cbf1 (diff)
Add libturbojpeg bindings.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index bdef4ce..61fd8d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,6 +25,16 @@ GUILE_PROGS
GUILE_MODULE_REQUIRED([gl])
GUILE_MODULE_REQUIRED([sdl2])
+PKG_CHECK_MODULES([TURBOJPEG], [libturbojpeg])
+PKG_CHECK_VAR([TURBOJPEG_LIBDIR], [libturbojpeg], [libdir])
+AC_MSG_CHECKING([libturbojpeg library path])
+AS_IF([test "TURBOJPEG_LIBDIR" = "x"], [
+ AC_MSG_FAILURE([Unable to identify libturbojpeg lib path.])
+], [
+ AC_MSG_RESULT([$TURBOJPEG_LIBDIR])
+])
+AC_SUBST([TURBOJPEG_LIBDIR])
+
PKG_CHECK_MODULES([OpenAL], [openal])
PKG_CHECK_VAR([OPENAL_LIBDIR], [openal], [libdir])
AC_MSG_CHECKING([OpenAL library path])