summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2017-01-04 22:16:26 -0500
committerDavid Thompson <dthompson2@worcester.edu>2017-01-04 22:16:26 -0500
commit98dc87a054c1108bd5f4bb093024d962ce0c8ce2 (patch)
tree9fa25dca82134bcdbe8693bfd5b212ce3b3880f8 /configure.ac
First commit!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..d3ced53
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,26 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(chickadee, 0.1.0)
+AC_CONFIG_SRCDIR(chickadee)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([color-tests -Wall -Wno-portability foreign])
+AM_SILENT_RULES([yes])
+
+AC_PATH_PROG([GUILE], [guile])
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+AC_CONFIG_FILES([chickadee/config.scm])
+
+# Prepare a version of $datadir that does not contain references to
+# shell variables.
+chickadee_prefix="`eval echo $prefix | sed -e"s|NONE|/usr/local|g"`"
+chickadee_datadir="`eval eval echo $datadir | sed -e "s|NONE|$chickadee_prefix|g"`"
+AC_SUBST([chickadee_datadir])
+
+GUILE_PKG([2.2 2.0])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([gl])
+GUILE_MODULE_REQUIRED([sdl2])
+
+AC_OUTPUT