summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2021-09-08 09:04:44 -0400
committerDavid Thompson <dthompson2@worcester.edu>2021-09-08 09:05:35 -0400
commit37312bb2c9ce6f2bb778e043a8697729bce81a0a (patch)
treea406ec66f4b3dc95996476b43541a6a818c6aa0c /Makefile.am
parent7e4a2e25e86aed646621f2a4ba019fa0a6307b51 (diff)
Add the start of a test suite.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c10d13..806157f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -93,6 +93,13 @@ SOURCES = \
chickadee/scripting.scm \
chickadee.scm
+TESTS = \
+ tests/math/vector.scm
+
+TEST_EXTENSIONS = .scm
+SCM_LOG_COMPILER = $(top_builddir)/test-env $(GUILE)
+AM_SCM_LOG_FLAGS = --no-auto-compile -L "$(top_srcdir)"
+
EXTRA_DIST += \
COPYING \
run-example \
@@ -121,7 +128,8 @@ EXTRA_DIST += \
examples/images/serene-village.png \
examples/maps/example.tmx \
examples/maps/serene-village.tsx \
- examples/models/suzanne.obj
+ examples/models/suzanne.obj \
+ tests/utils.scm
dist_pkgdata_DATA = \
data/AUTHORS \