summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2018-12-13 21:20:42 -0500
committerDavid Thompson <dthompson2@worcester.edu>2018-12-13 21:28:08 -0500
commit75c5cdef5c72b4f88ae71ba37e7a94b609996279 (patch)
tree8f867222da14159cdcf4682dd90fdad1d1fc8a07 /Makefile.am
parentfa30685ab7f8a3e44bc144b68a8516ba31de3cc4 (diff)
Re-hide SDL2 details.
I know I'm backpedaling here, but I think it was a mistake to expose SDL2 as much as I have here. I think it's better for people just getting started to not have to wonder what SDL means. Making things as usable as possible for beginners is an important goal, and abstracting SDL2 + OpenGL things from the core game loop implementation shouldn't require sacrificing that goal. * chickadee.scm: Switch code with... * chickadee/game-loop.scm: ...this! Which is copied straight from... * chickadee/sdl.scm: ...this! Which is now deleted. * Makefile.am (SOURCES): Add game-loop.scm, remove sdl.scm. * examples/grid.scm: Update due to API breakage. * examples/lines.scm: Ditto. * examples/nine-patch.scm: Ditto. * examples/sprite.scm: Ditto. * examples/text.scm: Ditto. * examples/tiled.scm: Ditto. * doc/api.texi (Kernel): Update.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index dbcc9ba..d80831a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,7 @@ godir=$(libdir)/guile/$(GUILE_EFFECTIVE_VERSION)/ccache
SOURCES = \
chickadee/config.scm \
chickadee/utils.scm \
+ chickadee/game-loop.scm \
chickadee/json.scm \
chickadee/heap.scm \
chickadee/array-list.scm \
@@ -75,8 +76,7 @@ SOURCES = \
chickadee/scripting/script.scm \
chickadee/scripting/channel.scm \
chickadee/scripting.scm \
- chickadee.scm \
- chickadee/sdl.scm
+ chickadee.scm
EXTRA_DIST += \
COPYING \