Remove problematic OpenGL requirements.
authorDavid Thompson <davet@gnu.org>
Mon, 25 Jun 2018 08:30:14 +0000 (04:30 -0400)
committerDavid Thompson <davet@gnu.org>
Mon, 25 Jun 2018 08:30:14 +0000 (04:30 -0400)
commitdd35ec3c1a087ffe14367643c040f8012d9f70bc
treeaad1f2413ef3c195ba6ad7209e775556c5d89b4b
parentab6bea9c601e00cd63d81fa94ec177267e70c2e4
Remove problematic OpenGL requirements.

Trying to force certain GL versions and other attributes has only
caused problems for potential users thus far.  Let's see how far we
get by just removing this stuff.

* chickadee/window.scm (open-window): Remove OpenGL settings.
* chickadee/render/shapes.scm (draw-filled-rect, draw-line): Drop
shader version from 330 to 130.
* chickadee/render/sprite.scm (default-shader): Same.
chickadee/render/shapes.scm
chickadee/render/sprite.scm
chickadee/window.scm