summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Thompson <dthompson2@worcester.edu>2023-05-24 08:54:11 -0400
committerDavid Thompson <dthompson2@worcester.edu>2023-05-24 08:54:11 -0400
commitc1d5240aecab77021c262b9ad1ac27df54b59017 (patch)
treec35ce43231eef223171503f6c6ec5fe33966abc2 /configure.ac
First commit!
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..65d48cc
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,17 @@
+dnl -*- Autoconf -*-
+
+AC_INIT(chickadee-game-template, 0.1.0)
+AC_CONFIG_SRCDIR(game)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([foreign -Woverride -Wno-portability])
+AM_SILENT_RULES([yes])
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+
+GUILE_PKG([3.0])
+GUILE_PROGS
+
+GUILE_MODULE_REQUIRED([chickadee])
+
+AC_OUTPUT